Форум: Техническая поддержка

Тема: Актуальная Lusbapi

Вы не вошли.

 Поиск | Регистрация | Вход 

01.06.2021 00:44:00
#1

Участник
Здесь с 21.05.2021
Сообщений: 7

Актуальная Lusbapi

Здравствуйте.

Сообщите, пожалуйста, когда можно ожидать выхода версии библиотеки Lusbapi с поддержкой современных операционных систем - Win10-x64, Win7-x64 ?

Предлагаемая для использования в 64-битных ОС библиотека lcomp, похоже, уже не поддерживается ...


L-Card E14-440

01.06.2021 03:42:02
#2

Сотрудник "Л Кард"
Здесь с 17.04.2014
Сообщений: 1,086

Re: Актуальная Lusbapi

Здравствуйте.

Сами 32-битные приложения могут без проблем работать на 64-битных ОС (Win10-x64, Win7-x64) не хуже 64-битных, за исключением случаев, когда приложению может потребоваться более 2 ГБайт оперативной памяти.
Но в принципе возможно выложить 64-битную сборку lusbapi, для какого-то клиента делалась такая сборка.

С другой стороны, как я понимаю Ваш вопрос связан с темой https://www.lcard.ru/forums/viewtopic.php?id=10373. Если да, то lusbapi - библиотека на C++ с использованием виртуальных функций и в ней будет та же проблема с виртуальной таблицей, что и в lcomp, для которой в рамках lusbapi не уверен, что есть хорошее решение, т.к. у нее нет C-интерфейса, аналогичного wlcomp.

Библиотеки на С намного более подходят для использования в других языках и скорее всего именно создание pascal-интерфейса над wlcomp тут наиболее правильный путь. По крайней мере с таким подходом в E-502 и LTR, где библиотеки изначально на C, не помню каких-то проблем с Lazarus (по крайней мере под Linux были клиенты, которые его использовали) и 64-битным Delphi.

02.06.2021 17:37:52
#3

Участник
Здесь с 16.03.2021
Сообщений: 11

Re: Актуальная Lusbapi

С lusbapi и Lazarus'ом та же история, в Delphi это работает, с fpc нет, я сознательно использовал в качестве примера LComp, поскольку там классы инициализируются сразу один раз, в lusbapi это происходит в ходе поиска слота в цикле и ловить ошибки сложно.
Относительно Delphi чтобы это заработало в Delphi необходимо, чтобы версия lusbapi была не ниже 3.3, сейчас на сайте выложена версия 3.4. Кроме того, если Вы работаете на 64 битной ОС, то следует установить 64-х битный драйвер, он устанавливается программой LComp. Сама библиотека lusbapi 32-х битная, поэтому скомпилируйте свою программу, как 32-х битное приложение, если, конечно, Вам не пришлют 64-х битную версию lusbapi!
Ну, насчет Lazarus'а? Я вчера отправил запрос в техподдержку насчет pascal-интерфейса над wlcomp, пока молчат. Можно, конечно попытаться этот интерфейс сделать самим, но лучше, если это будет делать человек более опытный, я хочу просто получить хоть какой то ответ на мой запрос (подтверждение или отказ) и, исходя из этого ответа я решу, что делать дальше. Вы бы тоже отправили соответствующий запрос в техподдержку на ту же тему, это было бы полезно

Контакты

Адрес: 117105, Москва, Варшавское шоссе, д. 5, корп. 4, стр. 2

Многоканальный телефон:
+7 (495) 785-95-25
Факс: +7 (495) 785-95-14

Отдел продаж: sale@lcard.ru
Техническая поддержка: support@lcard.ru

Время работы: с 9-00 до 19-00 мск

L-CARD в проектах